WeenieCampbell.com

The Unwound Third => Site Announcements, Tips & Trouble Reports => Topic started by: GhostRider on August 31, 2011, 05:23:28 PM

Title: Unread Posts
Post by: GhostRider on August 31, 2011, 05:23:28 PM
Uncle John :

All the time I've been using the Weenie website, I review Unread Posts, by clicking on it on the left side. After I read one I use the browser's (Explorer) back button to go back to the list, which now does not contain the unread post I viewed.

In the last week, when I do this the the page has deleated all unread posts not just the one I just read, as it did before. It never did this before and when it happens I can't bring back ther unread "Unread Posts" list.

Is this a recent change?

Thanks,
Alex
Title: Re: Unread Posts
Post by: Pan on August 31, 2011, 11:28:31 PM
FWIW I have the same problem as Alex with Firefox 6.0.1.

I can find the posts however, going back and clicking the "find all the unread posts" button.

Cheers

Pan
Title: Re: Unread Posts
Post by: Parlor Picker on September 01, 2011, 12:44:44 AM
Same here - it never used to happen. However, as mentioned you can call up the other unread posts that have apparently disappeared.
Title: Re: Unread Posts
Post by: dj on September 01, 2011, 03:23:25 AM
I'll pile on here.  I went to Firefox 6.0 the day the Weenie server was updated.  Since then, I've had the problem with unread posts.  Is anyone who's had this problem NOT on Firefox 6.0/6.0.1?
Title: Re: Unread Posts
Post by: Nicolas Dussart on September 01, 2011, 03:35:56 AM
Yes I have the same problem with Firefox, Chrome and Opera on different computers
Title: Re: Unread Posts
Post by: alyoung on September 01, 2011, 05:42:51 AM
Yep, on good ol IE8 yesterday and today. Particularly vexing yesterday as it was my first visit for a coupla day ... and boom, all gone as soon as I clicked "back" after reading the first one.
Title: Re: Unread Posts
Post by: Parlor Picker on September 01, 2011, 05:57:29 AM
Seems to affect every browser then. (I'm using the latest Firefox).

Edit: Didn't happen just now. It seems to be an intermittent problem.
Title: Re: Unread Posts
Post by: uncle bud on September 01, 2011, 06:35:32 AM
I was able to duplicate the problem yesterday but not this morning. Mysterious. A cookie problem?
Title: Re: Unread Posts
Post by: LB on September 01, 2011, 07:25:07 AM
I read this thread then clicked BACK button to return to the unread posts page and it was empty. That's the first time it's ever happened on PC or Mac. I'm on the mac today. I clicked a link that said "Try unread" and they came back.

I just tried again visiting an hour later and I'm not seeing the issue now.
Title: Re: Unread Posts
Post by: Pan on September 01, 2011, 08:59:35 AM
Update: the "unread post"s seem to work, at least for now. Go figure.

Cheers

Pan
Title: Re: Unread Posts
Post by: sustaireblues on September 01, 2011, 02:55:55 PM
For about a week now, unread posts hasn't worked for me at all. I'm using safari on a mac. This time unread posts came up, I saw this thread, went to it and when I tried to go back, all unreads were gone. Tried hitting unread post search again and still came up empty. I'm having to search thru the index to find recent posts.

A real pain,
Joe
Title: Re: Unread Posts
Post by: GhostRider on September 01, 2011, 04:34:33 PM
Tried it again, this time hitting Unread Posts again on the left, instead of hitting the browser Back button.

Same result, all gone, and nothing I tried would bring the list back.

Alex
Title: Re: Unread Posts
Post by: uncle bud on September 01, 2011, 04:40:41 PM
We're looking into it. May need to consult a teenager.
Title: Re: Unread Posts
Post by: GhostRider on September 01, 2011, 04:55:56 PM
We're looking into it. May need to consult a teenager.

 :D
Title: Re: Unread Posts
Post by: Slack on September 01, 2011, 07:54:45 PM
Same thing happens to me -- I'll check it out.  In the meantime after hitting the back button you can click the link "click here to try all unread topics".

click here to try all unread topics/url] (http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=unread;all;start=0)
Title: Re: Unread Posts
Post by: Slack on September 01, 2011, 07:56:14 PM
I have problems modifying a post as well.  Let me see what I can find out.
Title: Re: Unread Posts
Post by: Slack on September 02, 2011, 06:01:38 AM
I think Uncle Bud is right -- it is probably a cookie problem.  I'm going to reset the cookie name for the forum, which will require everyone to log back in.  If you've forgotten your password, email me your user name and the password you'd like to use.  :D
Title: Re: Unread Posts
Post by: Parlor Picker on September 02, 2011, 07:01:54 AM
I was just told I couldn't access the Unread posts page and it asked for my Login and Password again.

Not a problem as I'm here now.
Title: Re: Unread Posts
Post by: Slack on September 02, 2011, 07:06:13 AM
Yes, if folks will log out and then log back in, I think that will take care of the problem.  You may have to logout out and in a few times.
Title: Re: Unread Posts
Post by: Slack on September 03, 2011, 09:19:54 AM
Well, resetting the forum cookie did not help a darn thing.   So back it goes to host support.
Title: Re: Unread Posts
Post by: alyoung on September 04, 2011, 05:04:31 AM
No change for me ... I still lose the "unread" list as soon as I try to go back to it, and the "read all unread posts" option also draws blank.
But ... a cumbersome workaround: log into Weenie and call up the unread posts list. Then open a new tab, log into Weenie again and use the search facility to call up the posts you want to look at. Clunky? Yep. Works? Yep.
Title: Re: Unread Posts
Post by: sustaireblues on September 04, 2011, 06:37:49 AM
I still can't get unread posts to work for me at all. Keeps saying no new posts since last visit. Then again, maybe there's just not anybody there.
I'm all alone!  :(

Joe
Title: Re: Unread Posts
Post by: uncle bud on September 04, 2011, 08:44:12 AM
Still mysterious.

For another option for reading recent posts, you can click the link for View the Most Recent Posts on the Forum (http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=recent), located just above the Users Online section towards the bottom of your screen on the main Forum Index page.

Or you can click this link: http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=recent

This will give you the most recent posts all together on one page, and you can click through to the threads as you like. It doesn't track posts you've read of course, but it's a quick way to scan recent stuff.

Title: Re: Unread Posts
Post by: Slack on September 04, 2011, 10:00:15 AM
Yup, I'm still exchanging emails on the problem.
Title: Re: Unread Posts
Post by: Slack on September 05, 2011, 09:39:08 AM
Strange problem, we're still looking at it.

The Unread Posts works correctly if you use the link "click here to try all unread topics" and then use the browsers back button, it works correctly.  The two forum commands are very similar.

So this works:
http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=unread;all;start=0

This does not:
http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=unread
Title: Re: Unread Posts
Post by: uncle bud on September 05, 2011, 09:58:27 AM
I blame Alex. He started the thread.
Title: Re: Unread Posts
Post by: Slack on September 05, 2011, 10:09:42 AM
I wasn't going to say anything, but... we may have to use the nation sack mojo hand on Alex.
Title: Re: Unread Posts
Post by: Stuart on September 05, 2011, 11:23:24 AM
Just tried to post and received the following message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@weeniecampbell.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Title: Re: Unread Posts
Post by: Slack on September 05, 2011, 11:24:59 AM
Reported to our host - thanks Stuart!
Title: Re: Unread Posts
Post by: alyoung on September 05, 2011, 06:07:52 PM
So this works:
http://weeniecampbell.com/yabbse/index.php?amp;Itemid=128&action=unread;all;start=0

No it doesn't ... well, not for me. This whole thing is getting weirder. I logged in last night and it worked just it did when I joined up -- I was able to to work my way thru the unread posts list by using the "back" button; today, clicking "back" tells me there are no new listings ... and neither of the alternatives Slack has suggested works. Back to the double login... 
Title: Re: Unread Posts
Post by: alyoung on September 05, 2011, 07:56:36 PM
Well, that'll teach me to complain ... now I can't get into the forum tags. I login, I click on "Forum Tags" and up comes the message telling me I don't have access and I'll have to log in. But I AM logged in .... haaalp
Title: Re: Unread Posts
Post by: Johnm on September 05, 2011, 09:46:30 PM
Hi all,
I'm on a Mac and I've never had a problem with tags all through this period.  I have had problems returning to the unread posts after reading the first unread post, but could always get the remaining unread posts by going to either recent unread posts or all unread posts (I realize the last is not a feasible solution for newcomers to the site).  Just now the unread posts function worked for me as it always had in the past--returning and picking up the unread posts one by one until I had read them all.  I'll be interested to see if this improved performance holds.
All best,
Johnm
Title: Re: Unread Posts
Post by: dj on September 06, 2011, 04:35:54 AM
Unread Posts worked fine for me this morning.  Well, fine except that I only have an Unread Posts link from the Weenie Home page, not from any other page!

And I too have the problem with tags.  I can go to the tags page, but once I'm there, clicking on any tag tells me I have to log in.  But the Login Form tells me I am logged in.

Modified to add:

A bit more debugging gives the following results:  I only have the Unread Posts link from the Home page and the Tags page.  From the Tags page, clicking on any link except that to the Home page brings up a message telling me I have to log in.  Going to the Home page from the Tags page allows me to go to any other link.  All links from all other pages seem to work.  Tests run on Firefox 6.0.1.    
Title: Re: Unread Posts
Post by: Johnm on September 06, 2011, 06:54:42 AM
Hi all,
Tags are unusable for me now, too.
All best,
Johnm
Title: Re: Unread Posts
Post by: Slack on September 06, 2011, 06:59:59 AM
For the TAGS problems, log out and then log back in.   We use two systems that are bridged (mambo and SMF forum) - and it means that you are logged into one system but not the other.  If you log out and log in -- you should be in both.
Title: Re: Unread Posts
Post by: Slack on September 06, 2011, 07:03:03 AM
And when you log out and log back in -- please use the form on the left column.

Unread Posts is now working for me. 
Title: Re: Unread Posts
Post by: dj on September 06, 2011, 07:39:55 AM
Much better.  Thanks.
Title: Re: Unread Posts
Post by: alyoung on September 06, 2011, 07:46:44 AM
For the TAGS problems, log out and then log back in.   We use two systems that are bridged (mambo and SMF forum) - and it means that you are logged into one system but not the other.  If you log out and log in -- you should be in both.

Tried that ... a couple of time as soon as the problem occurred, then I left it for a few hours and tried again. Same result -- a message saying: You are not authorized to view this resource. You need to login.

BUT... the unread posts worked!! Now if I could only get the tags back....
Title: Re: Unread Posts
Post by: Bunker Hill on September 06, 2011, 09:12:06 AM
Tried that ... a couple of time as soon as the problem occurred, then I left it for a few hours and tried again. Same result -- a message saying: You are not authorized to view this resource. You need to login.
Just got in I'm having the same problem, was ok this morning. Each time I close the browser and reopen, the left hand column tells me I'm logged in but when I click on anything that message appears. I log out and log in again, which is fine until I close out and attempt a reopen. (using Mac 10.6.8 with Safari)
Title: Re: Unread Posts
Post by: Slack on September 06, 2011, 09:17:10 AM
Are you checking the box, login forever?
Title: Re: Unread Posts
Post by: Slack on September 06, 2011, 09:18:16 AM
But I see what you mean.  What happens if you use the Tags menu item at the top of the forum (as opposed to the left menu)?
Title: Re: Unread Posts
Post by: Slack on September 06, 2011, 11:23:58 AM
We're getting closer.  Please try logging out and back in and see if it is not all fixed.

Thanks.  (turns out it was a new server setting. :) )
Title: Re: Unread Posts
Post by: Gumbo on September 06, 2011, 12:34:34 PM
I have working tags now and didn't lose my unread topics
which is the first time for days
looks good
Title: Re: Unread Posts
Post by: Richard on September 06, 2011, 01:20:13 PM
Seems to be fine, thanks for the effort.
Title: Re: Unread Posts
Post by: uncle bud on September 06, 2011, 01:36:31 PM
All working well for me. Looking good.
Title: Re: Unread Posts
Post by: Johnm on September 07, 2011, 10:30:14 AM
All is working well for me, too.  Thanks to John D. and Jason for trouble-shooting these problems.
All best,
Johnm
Title: Re: Unread Posts
Post by: alyoung on September 08, 2011, 04:39:44 AM
I echo JohnM ... everything working as it should again -- marvellous. Many thanks to all who solved it.
Title: Re: Unread Posts
Post by: dj on November 29, 2011, 05:11:39 AM
I've been having the problem with the list of unread posts emptying after I read the first one for a few days now.  Is anyone else seeing this? 
Title: Re: Unread Posts
Post by: Parlor Picker on November 29, 2011, 06:40:35 AM
Everything working as normal for me.
Title: Re: Unread Posts
Post by: Slack on November 29, 2011, 06:45:11 AM
Works for me too.  You are flipping back using your browser back button, yes?
Title: Re: Unread Posts
Post by: dj on November 29, 2011, 07:36:21 AM
Well.  It works for me now, too.  It hasn't since Saturday.  I tried using both the browser's back button and reclicking "Recent Unread Topics", and both have left me with an empty list until right now. 
Title: Re: Unread Posts
Post by: Slack on November 29, 2011, 07:42:12 AM
Those are the kinds of problems I like.  ;D
SimplePortal 2.3.7 © 2008-2020, SimplePortal